Rise 360: Course Authoring Unavailable
Incident Report for Articulate
Resolved
This issue is now resolved. Thank you for your patience!
Posted Mar 27, 2024 - 02:42 UTC
Monitoring
Rise 360 is loading normally again, and we're monitoring the situation carefully.
Posted Mar 27, 2024 - 01:54 UTC
Investigating
We are experiencing an issue where the Rise 360 isn't loading. We're looking into what went wrong, and we'll keep you updated right here. We're so sorry for the trouble!
Posted Mar 27, 2024 - 01:30 UTC
This incident affected: Articulate ID, E-Learning Heroes, and Articulate.com.