Articulate Store - Issue Processing Orders
Incident Report for Articulate
Resolved
This incident has been resolved.
Posted Mar 24, 2024 - 00:34 UTC
Monitoring
A fix has been implemented and we are monitoring results.
Posted Mar 23, 2024 - 23:37 UTC
Investigating
We're currently experiencing an issue with the processing of orders. We're looking into the issue and have paused ordering in the meantime. We're sorry for any trouble and will let you know when we're back online!
Posted Mar 23, 2024 - 23:12 UTC
This incident affected: Articulate.com and Articulate 360 (Account Management).