Articulate 360 Teams admin management is unavailable
Incident Report for Articulate
Resolved
This issue is resolved. Articulate 360 Teams admins should be able to access the admin tab within their account.
Posted 3 months ago. Jan 16, 2019 - 19:07 UTC
Investigating
We’ve identified an issue that may prevent Articulate 360 Teams admins from being able to access the admin tab within their account. Users may be unable to manage admin users, such as adding, removing, or assigning groups. We’re working on a fix and will let you know as soon as we have more information.
Posted 3 months ago. Jan 16, 2019 - 18:52 UTC
This incident affected: Account Management.