Articulate 360: Issue with Account Management
Incident Report for Articulate
Resolved
We've resolved this issue. Articulate 360 admins can access the Seats tab as expected.
Posted Jun 05, 2020 - 12:46 UTC
Monitoring
We've implemented a fix for this issue. Articulate 360 admins should be able to view the Seats tab again. If you're still experiencing the issue, please refresh your page. We'll continue to monitor progress carefully.
Posted Jun 04, 2020 - 20:37 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 04, 2020 - 18:58 UTC
Identified
We've identified the cause of this issue, and we're working on a fix. We'll keep you updated on our progress.
Posted Jun 04, 2020 - 16:07 UTC
Investigating
Hi Articulate 360 admins, we’re investigating an issue that’s causing the Seats tab to appear blank. We’re working on getting this fixed, and we’ll let you know as soon as we have more info. We’re so sorry for any trouble.
Posted Jun 04, 2020 - 14:22 UTC
This incident affected: Articulate 360 (Account Management).