Review 360: Review 360 is currently experiencing degraded performance
Incident Report for Articulate
Resolved
Review 360 is performing normally, and this issue has been resolved.
Posted Dec 06, 2022 - 23:29 UTC
Monitoring
Review 360 items are now loading fine. A fix has been implemented and we’ll continue to monitor performance carefully.
Posted Dec 06, 2022 - 22:39 UTC
Investigating
Review 360 is currently loading slowly and sometimes timing out or showing the "you're offline" banner.
We’re investigating it and will let you know as soon as we have more information. We’re so sorry for any trouble.
Posted Dec 06, 2022 - 22:08 UTC
This incident affected: Articulate ID, E-Learning Heroes and Articulate 360 (Review 360).