Delays loading and downloading some Content Library stock assets
Incident Report for Articulate
Resolved
We've confirmed that everything is back to normal.
Posted Mar 15, 2018 - 14:53 UTC
Monitoring
Load and download times for Content Library stock assets appear to be back to normal. We're going to continue to monitor the situation.
Posted Mar 14, 2018 - 14:59 UTC
Investigating
Hi there, Articulate 360 subscribers. We’ve noticed an issue that’s causing some stock assets in Content Library to load more slowly in search and take more time to download to your computer. At this time, we don’t know of any workarounds. We're sorry for the trouble!
Posted Mar 13, 2018 - 21:00 UTC