Possible errors with e-commerce purchases
Incident Report for Articulate
Resolved
We've confirmed that our e-commerce process is running normally.
Posted Aug 15, 2018 - 14:46 UTC
Monitoring
We're seeing some issues with our e-commerce process, so you may encounter errors when trying to purchase apps on articulate.com. We're working on this, and we’ll let you know when we have any new information. We're sorry for the trouble!
Posted Aug 15, 2018 - 14:28 UTC