Articulate.com is unavailable
Incident Report for Articulate
Resolved
We've confirmed that articulate.com is working normally.
Posted about 1 month ago. Sep 20, 2019 - 22:22 UTC
Update
Articulate.com is currently back up, but we're still working on fixing this issue. It may be intermittently unavailable while we're working on it, and we'll keep you posted.
Posted about 1 month ago. Sep 20, 2019 - 15:50 UTC
Investigating
Articulate.com is currently unavailable, and we’re looking into what went wrong. We’ll let you know as soon as we have more info. We’re so sorry for the trouble.
Posted about 1 month ago. Sep 20, 2019 - 15:40 UTC
This incident affected: Articulate.com.