Articulate.com: Slow processing time when purchasing Articulate 360
Incident Report for Articulate
Resolved
Our website is back up and running as usual.
Posted Jul 20, 2018 - 16:34 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 20, 2018 - 16:15 UTC
Update
We've temporarily de-activated our online store to fix this issue. It should only be unavailable for about five minutes. We'll keep you posted.
Posted Jul 20, 2018 - 16:15 UTC
Identified
You may notice some delays if you submit an order for Articulate 360 right now. We're working on getting this fixed up, and we'll keep you posted. So sorry for the trouble!
Posted Jul 20, 2018 - 15:36 UTC