Articulate 360: Articulate Review is unavailable for some users
Incident Report for Articulate
Resolved
Articulate Review is back up and running normally.
Posted Apr 17, 2018 - 20:32 UTC
Monitoring
We've rolled out a fix for this issue, and we've confirmed that Articulate Review is working normally. We'll continue to monitor this carefully!
Posted Apr 17, 2018 - 18:24 UTC
Investigating
Articulate Review is currently slow or unavailable for some customers. We're looking into what's going on and we'll keep you posted. We're so sorry for the trouble.
Posted Apr 17, 2018 - 15:49 UTC