Rise 360: Dashboard Not Loading
Incident Report for Articulate
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 20:48 UTC
Monitoring
We've implemented a fix, and Rise 360 is working normally again. We'll continue to monitor performance carefully.
Posted Sep 14, 2021 - 20:02 UTC
Investigating
The Rise 360 dashboard is not loading right now. We're looking into what's going on, and we'll keep you posted. We're so sorry for the trouble.
Posted Sep 14, 2021 - 19:26 UTC
This incident affected: Articulate 360 (Rise 360).