Buying Storyline 3 and Studio '13 on Articulate.com is temporarily unavailable
Incident Report for Articulate
Resolved
Our e-commerce provider has fixed this issue, and we've confirmed that our online purchasing is working normally.
Posted Mar 08, 2018 - 17:00 UTC
Identified
Hi there, Articulate.com visitors. We’re having an issue with our e-commerce provider so you won’t be able to buy Storyline 3 and Studio '13 on our site right now. We’ll let you know when we have an update. We're so sorry for the trouble!
Posted Mar 08, 2018 - 15:39 UTC