Articulate IDs: Resetting passwords is unavailable
Incident Report for Articulate
Resolved
This issue has been resolved. Resetting the password for your Articulate ID is working normally again.
Posted Jul 11, 2018 - 18:40 UTC
Investigating
Currently, you won't be able to reset the password for your Articulate ID. We’re looking into what went wrong, and we’ll let you know as soon as we have a fix in the works. We’re so sorry for the trouble.
Posted Jul 11, 2018 - 18:32 UTC
This incident affected: Articulate ID.