Issues signing up for an account
Incident Report for Articulate
Resolved
We've confirmed that sign-ups are back to running normally.
Posted Apr 17, 2018 - 21:15 UTC
Investigating
Hi there. We’ve noticed an error that’s impacting account sign-ups, including signing up for a free trial of Articulate 360. You may also experience issues making changes to you account details such as modifying your name and e-mail address. We don’t know of any workarounds at this time. So sorry for the trouble!
Posted Apr 17, 2018 - 19:59 UTC