Articulate 360: Account management log-in errors
Incident Report for Articulate
Resolved
Login via account.articulate.com has been restored.
Posted Nov 19, 2019 - 22:01 UTC
Monitoring
We've fixed this issue, and confirmed you can sign in normally on account.articulate.com. We'll continue to monitor performance carefully.
Posted Nov 19, 2019 - 20:07 UTC
Identified
Hi there, Articulate 360 users. Right now, you may not be able to log in to account.articulate.com. We're working on getting this fixed, and we'll keep you posted. We're so sorry for any trouble.
Posted Nov 19, 2019 - 18:51 UTC
This incident affected: Articulate 360 (Account Management).