Purchasing Storyline 3, Studio ’13, and Articulate Online is unavailable
Incident Report for Articulate
Resolved
This incident has been resolved.
Posted Sep 07, 2018 - 21:25 UTC
Monitoring
Our online store is back up and running normally. We'll continue to monitor performance carefully.
Posted Sep 07, 2018 - 20:06 UTC
Investigating
Hi there. Currently purchasing Storyline 3, Studio ’13, and Articulate Online is unavailable. We’ll let you know as soon as we have more info. We’re so sorry for any trouble.
Posted Sep 07, 2018 - 19:28 UTC