Slow processing time when purchasing Articulate 360
Incident Report for Articulate
Resolved
Our website is back up and running as usual.
Posted Sep 12, 2018 - 14:51 UTC
Monitoring
You should no longer experience a delay if you submit an order for Articulate 360. We'll continue to monitor performance carefully.
Posted Sep 12, 2018 - 14:14 UTC
Identified
You may notice a delay or your session may time out if you submit an order for Articulate 360 right now. We’ll keep you posted on our progress as we work to resolve this issue. We’re so sorry for any trouble!
Posted Sep 12, 2018 - 13:58 UTC