Rise 360 is currently unavailable
Incident Report for Articulate
Resolved
This issue has been resolved. Rise 360 is working as expected.
Posted Jun 19, 2019 - 17:08 UTC
Monitoring
Rise 360 is available again. You should be able to access Rise 360 and Rise 360 courses normally. We're so sorry for any trouble!
Posted Jun 19, 2019 - 15:57 UTC
Investigating
We're investigating an issue that's preventing access to Rise 360 and Rise 360 courses. We'll let you know as soon as we have more information available.
Posted Jun 19, 2019 - 15:32 UTC
This incident affected: Articulate 360 (Rise 360).