Articulate Online: Uploading content is unavailable
Incident Report for Articulate
Resolved
We've confirmed that Articulate Online is back up and running normally.
Posted about 1 month ago. May 11, 2018 - 23:53 UTC
Investigating
We’re having an issue with Articulate Online servers right now that's making content uploads unavailable. Everything else should be working just fine. We're investigating the cause of the problem, and we’ll let you know when we have a fix. We're so sorry for the trouble!
Posted about 1 month ago. May 11, 2018 - 23:07 UTC