Long loading times on articulate.com
Incident Report for Articulate
Resolved
We've fixed this issue and articulate.com is back up and running as usual.
Posted Jun 12, 2018 - 14:38 UTC
Investigating
We're hearing about some longer-than-usual loading times on articulate.com and we're looking into what's causing this. We'll keep you posted, and we're sorry for the trouble!
Posted Jun 12, 2018 - 14:13 UTC