Articulate IDs: Resetting passwords is unavailable
Incident Report for Articulate
Resolved
This issue has been resolved. You can now reset the password for your Articulate ID. We're sorry for any inconvenience!
Posted Jul 13, 2018 - 17:23 UTC
Identified
We've identified the issue and are working on a fix.
Posted Jul 13, 2018 - 16:57 UTC
Investigating
Currently, you won’t be able to reset the password for your Articulate ID. We’re looking into what went wrong, and we’ll let you know as soon as we have a fix in the works. We’re so sorry for the trouble.
Posted Jul 13, 2018 - 16:46 UTC
This incident affected: Articulate ID.