Articulate 360 and E-Learning Heroes users may not be able to sign in to their Articulate IDs
Incident Report for Articulate
Resolved
Signing into E-Learning Heroes and Articulate 360 is working normally. We're so sorry for any trouble.
Posted Oct 18, 2017 - 22:07 UTC
Investigating
Hi there, Articulate 360 users and E-Learning Heroes community members. You may not be able to sign into your Articulate ID right now, and we’re investigating what’s going on. We’ll let you know as soon as we have more information.
Posted Oct 18, 2017 - 21:04 UTC