Articulate 360: Review 360 is currently unavailable
Incident Report for Articulate
Resolved
This incident has been resolved.
Posted Aug 28, 2019 - 20:47 UTC
Investigating
We're investigating an issue that's preventing Review 360 from loading. Currently, users are unable to access content in Review 360 and publish content from Rise 360 to Review 360. We'll let you know when we have more information. We're sorry for the trouble!
Posted Aug 28, 2019 - 19:26 UTC
This incident affected: Articulate 360 (Review).