Articulate 360: Purchasing Teams Subscriptions is Unavailable
Incident Report for Articulate
Resolved
We've confirmed that purchasing Articulate 360 Teams subscription is working again. We apologize for the interruption!
Posted May 13, 2022 - 18:59 UTC
Investigating
Hi there, Articulate 360 users. Right now, you may run into a blank checkout page when attempting to purchase an Articulate 360 Teams subscription. We're working to resolve this problem, and we'll update you as soon as possible. We're so sorry for the trouble!
Posted May 13, 2022 - 15:45 UTC
This incident affected: E-Learning Heroes and Articulate.com.