Issues subscribing to Articulate 360 and purchasing seats
Incident Report for Articulate
Resolved
We've confirmed that everything back to working normally.
Posted Apr 09, 2018 - 21:10 UTC
Monitoring
We're seeing that this issue is likely resolved, but we're continuing to monitor it. We'll let you know as soon as everything to working normally.
Posted Apr 09, 2018 - 18:39 UTC
Investigating
Hi there. We’ve noticed an error that’s preventing folks from subscribing to Articulate 360 or adding seats to their subscription. We’re working on a fix and will keep you informed. We’re so sorry for the trouble.
Posted Apr 09, 2018 - 17:32 UTC