Multiple Articulate Blogs are Temporarily Down
Incident Report for Articulate
Resolved
This incident has been resolved. You can access our blogs again.
Posted Jun 30, 2020 - 14:45 UTC
Identified
We’ve learned of a Wordpress outage that’s impacting access to the Rapid E-Learning Blog, the Articulate Life Blog, and our French and German Blogs. We’re working with Wordpress and will notify you when this issue is resolved.
Posted Jun 29, 2020 - 16:29 UTC