Purchasing Storyline 3, Studio '13, and Articulate Online is unavailable
Incident Report for Articulate
Resolved
We've confirmed that our online store is back up and running normally.
Posted Jul 17, 2018 - 19:54 UTC
Monitoring
Hi there. Currently, purchasing Storyline 3, Studio '13, and Articulate Online is unavailable. We’ll let you know as soon as we have more info. We’re so sorry for any trouble.
Posted Jul 17, 2018 - 19:29 UTC