Articulate.com and AID users: You might encounter delays with confirmation emails
Incident Report for Articulate
Resolved
This incident has been resolved.
Posted Nov 19, 2018 - 21:22 UTC
Update
We're still seeing some delays with email confirmations, but these should be caught up by tomorrow. We'll continue to keep you posted.
Posted Nov 15, 2018 - 21:51 UTC
Identified
We're having an issue with our authentication system that might cause delays in sending out email confirmations for signups. We'll keep you posted, and we're so sorry for the trouble.
Posted Nov 15, 2018 - 17:03 UTC
This incident affected: Articulate ID.