Articulate Store Unavailable

Incident Report for Articulate

Resolved

This incident has been resolved. Purchasing and processing of orders is working as expected.
Posted Jun 11, 2025 - 13:15 UTC

Monitoring

Our ordering systems are operational again, and our teams are actively monitoring them to ensure stability. Thank you for your continued patience.
Posted Jun 11, 2025 - 01:32 UTC

Identified

We've identified the issue affecting our purchasing pages and are working on a fix. Thanks for your patience, and sorry for the inconvenience!
Posted Jun 10, 2025 - 20:29 UTC

Investigating

Our team is currently investigating an issue affecting our purchasing pages—specifically, the inability to buy new subscriptions or add seats. As a result, we're temporarily unable to process orders for Articulate products.

We'll share updates here as soon as we have more information.
Posted Jun 10, 2025 - 13:15 UTC
This incident affected: Articulate 360 (Account Management).