Articulate.com: Creating trials and purchasing subscriptions is unavailable
Incident Report for Articulate
Resolved
This incident is now resolved. We're so sorry for the interruption!
Posted Jan 20, 2022 - 23:35 UTC
Monitoring
Creating free Articulate 360 trials and purchasing Articulate 360 subscriptions is working normally again, and we will continue to monitor the situation carefully.
Posted Jan 20, 2022 - 23:09 UTC
Investigating
Hi there, Articulate.com visitors! Right now you might find that you're unable to create a free trial for Articulate 360 or purchase an Articulate 360 subscription. We're working to figure out what went wrong, and we'll update you as soon as possible. We're so sorry for the trouble.
Posted Jan 20, 2022 - 21:55 UTC
This incident affected: Articulate.com.