Rise 360 Manage Blocks Unavailable

Incident Report for Articulate

Resolved

We implemented a fix for the issue affecting Manage Blocks in Rise 360. Functionality has been restored and the service has remained stable during monitoring.

This incident has been resolved.
Posted Jun 01, 2026 - 19:40 UTC

Monitoring

We implemented a fix for the issue affecting Manage Blocks in Rise 360. Functionality has been restored, and we are monitoring the service to ensure stability.
Posted Jun 01, 2026 - 18:34 UTC

Investigating

We are investigating an issue affecting Manage Blocks in Rise 360. Users may be unable to access or manage blocks after selecting a block from the Manage Blocks view.

Our team is actively investigating the issue and working to restore normal functionality.
Posted Jun 01, 2026 - 18:20 UTC
This incident affected: Articulate 360 (Rise 360).