Articulate ID: Users can’t log in across multiple services

Incident Report for Articulate

Update

We’ve implemented a fix for the login issue that impacted access to Articulate services, including Rise 360, Storyline 360, id.articulate.com, E-Learning Heroes Community, and our e-commerce site.
All systems are currently operational, and we’re closely monitoring performance to ensure stability.
Thank you for your patience!
Posted Dec 03, 2025 - 15:35 UTC

Update

We’ve implemented a fix for the login issue that impacted access to Articulate services, including Rise 360, Storyline 360, id.articulate.com, E-Learning Heroes Community, and our e-commerce site.
All systems are currently operational, and we’re closely monitoring performance to ensure stability.
Thank you for your patience!
Posted Dec 03, 2025 - 15:05 UTC

Monitoring

We’ve implemented a fix for the login issue that impacted access to Articulate services, including Rise 360, Storyline 360, id.articulate.com, E-Learning Heroes Community, and our e-commerce site.
All systems are currently operational, and we’re closely monitoring performance to ensure stability.
Thank you for your patience!
Posted Dec 03, 2025 - 15:05 UTC

Update

We’re currently investigating a login issue that’s preventing users from accessing Articulate services due to an outage with our third party provider. This includes the E-Learning Heroes Community, signing up for an Articulate 360 trial, Rise 360, Storyline 360, id.articulate.com, and our e-commerce site. Purchases cannot be completed and admins cannot manage SSO settings.
We’ll share more updates here as soon as we know more.
Thanks for your patience while we dig into this.
Posted Dec 03, 2025 - 14:54 UTC

Update

We’re currently investigating a login issue that’s preventing users from accessing Articulate services due to an outage with our third party provider. This includes the E-Learning Heroes Community, signing up for an Articulate 360 trial, Rise 360, Storyline 360, id.articulate.com, and our e-commerce site. Purchases cannot be completed and admins cannot manage SSO settings.
We’ll share more updates here as soon as we know more.
Thanks for your patience while we dig into this.
Posted Dec 03, 2025 - 14:41 UTC

Update

We’re currently investigating a login issue that’s preventing users from accessing Articulate services due to an outage with our third party provider. This includes the E-Learning Heroes Community, signing up for an Articulate 360 trial, Rise 360, Storyline 360, id.articulate.com, and our e-commerce site. Purchases cannot be completed and admins cannot manage SSO settings.
We’ll share more updates here as soon as we know more.
Thanks for your patience while we dig into this.
Posted Dec 03, 2025 - 14:12 UTC

Update

We’re currently investigating a login issue that’s preventing users from accessing Articulate services due to an outage with our third party provider. This includes the E-Learning Heroes Community, signing up for an Articulate 360 trial, Rise 360, Storyline 360, id.articulate.com, and our e-commerce site. Purchases cannot be completed and admins cannot manage SSO settings.
We’ll share more updates here as soon as we know more.
Thanks for your patience while we dig into this.
Posted Dec 03, 2025 - 14:06 UTC

Investigating

We’re currently investigating a login issue that’s preventing users from accessing Articulate services, including Rise 360, Storyline 360, and id.articulate.com. This also affects admins trying to manage SSO settings.
We’ll share more updates here as soon as we know more.
Thanks for your patience while we dig into this.
Posted Dec 03, 2025 - 13:37 UTC
This incident affects: Articulate 360 (Rise 360, Review 360, Account Management) and Articulate ID.