Rise 360 is currently unavailable
Incident Report for Articulate
Resolved
We've confirmed this issue is now fully resolved.
Posted Apr 20, 2022 - 04:27 UTC
Monitoring
Rise 360 is back online. We’ll continue to monitor performance carefully. We’re sorry for the interruption!
Posted Apr 20, 2022 - 04:19 UTC
Investigating
Rise 360 is currently unavailable, and we’re looking into what went wrong. We’ll let you know as soon as we have more info. We’re so sorry for any trouble.
Posted Apr 20, 2022 - 04:02 UTC
This incident affected: Articulate 360 (Rise 360) and E-Learning Heroes, Articulate.com.