Articulate.com is unavailable
Incident Report for Articulate
Resolved
We've confirmed that articulate.com is working normally.
Posted Sep 13, 2019 - 19:20 UTC
Monitoring
Articulate.com is back up and running, and we're monitoring its performance carefully.
Posted Sep 13, 2019 - 18:44 UTC
Investigating
Articulate.com is currently unavailable, and we're looking into what went wrong. We're so sorry for the trouble, and we'll keep you posted.
Posted Sep 13, 2019 - 18:37 UTC
This incident affected: Articulate.com and Store.