Articulate 360, Articulate.com, E-Learning Heroes, and Articulate Online: Intermittent errors
Incident Report for Articulate
Postmortem

On Tuesday, October 22 beginning at 18:00 UTC, Articulate 360 apps, Articulate.com, E-Learning Heroes, and Articulate Online were intermittently unavailable for seven hours and thirty minutes. This outage happened because our third-party cloud hosting provider experienced a DDoS (Distributed Denial of Service) against their DNS (Domain Name System) servers.

Between October 22 18:00 UTC and Wednesday, October 23 01:30 UTC, our users may have been impacted in various ways, including, but not limited to:

  • Receiving errors when visiting articulate.com and E-Learning Heroes (community.articulate.com)
  • The inability to upload content to Rise 360 and Review 360
  • The inability to publish content to Review 360 from Storyline 360 and Studio 360
  • Receiving errors when trying to access Articulate Online

Third-party internet service providers (ISPs) also applied their own DDoS mitigation procedures to diminish impact during this time. Their actions may have caused our users to experience lingering issues or errors outside of the seven-hour and thirty-minute window.

We know how crucial uptime and performance is for our users, and we're very sorry if it impacted your workday in any way. Our engineers maintained up-to-the-minute contact with the support engineers from our third-party cloud provider throughout the duration of the DDoS attack and mitigation to minimize impact wherever we could.

We’re currently working with our cloud provider to take steps to stop future attacks, and reduce the impact on our cloud hosting infrastructure in the unlikely event that mitigation isn't completely possible.

If you have any questions, please get in touch with our support team and we'll be happy to provide any additional detail we can.

Posted Nov 05, 2019 - 22:44 UTC

Resolved
We've been working closely with our cloud hosting provider to make sure that Articulate 360 apps, Articulate.com, E-Learning Heroes, and Articulate Online are up and running. Today, we're seeing normal performance through our monitoring services, and we'll continue to keep a close eye on it. We're so sorry if this outage slowed you down. If you're still having any problems, please open a case with our support team by emailing support@articulate.com.
Posted Oct 24, 2019 - 19:34 UTC
Identified
Our cloud hosting provider is experiencing a distributed denial of service attack which is resulting in delays and intermittent errors when accessing Articulate 360 apps, Articulate.com, E-Learning Heroes, and Articulate Online. We're looking into it and will let you know when it's fixed. We're sorry for the trouble!
Posted Oct 22, 2019 - 22:44 UTC
This incident affected: Articulate 360 (Review, Content Library, Content Library Images, Rise, Desktop 360 App Updates, Team Slides, Storyline 360 Text to Speech) and Articulate ID, E-Learning Heroes, Account Management, Articulate.com, Articulate Online, Store, Product Activation, Articulate Blogs, Tempshare.