Articulate 360: Delays with logging in and accessing our platform

Incident Report for Articulate

Resolved

Articulate services have returned to normal. We apologize for the disruption and appreciate your patience!
Posted Mar 24, 2025 - 19:39 UTC

Monitoring

Hi Articulate 360 users! We are aware that users are experiencing delays with logging in and accessing our platform. We’ve implemented a solution that we’ll be monitoring throughout the weekend. We’re sorry for the trouble and appreciate your patience!
Posted Mar 21, 2025 - 20:32 UTC
This incident affected: Articulate 360 (Rise 360, Review 360, Reach 360, Team Slides, Articulate 360 Desktop App Updates, Storyline 360 Text to Speech, Articulate 360 Training, Content Library 360, Content Library Images 360, Account Management, AI Assistant, AI Images, Localization) and Articulate ID.