Rise is currently unavailable
Incident Report for Articulate
Resolved
Rise is back up and running.
Posted Aug 21, 2017 - 19:18 UTC
Investigating
Rise is currently unavailable, and we’re looking into what went wrong. We’ll let you know as soon as we have more info. We’re so sorry for any trouble.
Posted Aug 21, 2017 - 19:16 UTC