Review 360 is currently unavailable
Incident Report for Articulate
Resolved
This issue has been resolved. Review 360 is back up and running normally.
Posted 2 months ago. Feb 19, 2019 - 19:13 UTC
Monitoring
We've identified and fixed the issue that was causing Review 360 to be unavailable. We'll continue to monitor performance carefully.
Posted 2 months ago. Feb 19, 2019 - 16:07 UTC
Investigating
Review 360 is currently unavailable, and we’re looking into what went wrong. We’ll let you know as soon as we have more info. We’re so sorry for any trouble.
Posted 2 months ago. Feb 19, 2019 - 15:27 UTC
This incident affected: Articulate 360 (Review).