A fix has been implemented for the issue impacting AI image generation across Articulate 360 products. Creators can now generate images using AI Images as expected. We’re continuing to monitor performance to ensure the service remains stable.
Posted Mar 06, 2026 - 17:58 UTC
Identified
We’ve identified the issue impacting Image Generation. Our team is continuing to investigate this. Thank you for your patience.
Posted Mar 06, 2026 - 17:42 UTC
Update
We are continuing to work on a resolution for this issue.
Posted Mar 06, 2026 - 16:43 UTC
Update
We are continuing to work on a resolution for this issue.
Posted Mar 06, 2026 - 15:44 UTC
Investigating
We’re investigating an issue impacting AI image generation in Articulate 360 products. Creators are currently unable to generate images using AI Images. We’re actively looking into this and will share an update as soon as we have more information. Thanks for your patience while we work to restore full functionality.
Posted Mar 06, 2026 - 14:44 UTC
This incident affected: Articulate 360 (AI Images).