Articulate 360: Issues with images loading in Rise 360 and Review 360
Incident Report for Articulate
Resolved
We've confirmed that Rise 360 and Review 360 are working normally. We’re so sorry for the trouble.
Posted 7 months ago. Feb 19, 2019 - 21:52 UTC
Monitoring
We've implemented a fix for this issue and will continue to monitor performance carefully.
Posted 7 months ago. Feb 19, 2019 - 21:09 UTC
Update
We are continuing to investigate this issue.
Posted 7 months ago. Feb 19, 2019 - 20:50 UTC
Investigating
Hi there, Articulate 360 users. Right now, you won’t be able to view or upload images in Rise 360 and Review 360. We're investigating the cause of the problem, and we’ll let you know when we have any new information. We're so sorry for the trouble!
Posted 7 months ago. Feb 19, 2019 - 20:40 UTC
This incident affected: Articulate 360 (Review, Rise).