The issue is resolved, and posted content should appear normally now. If you have any questions or need to report any issue, please reach out at https://articulatecase.com.
Posted Mar 17, 2025 - 16:11 UTC
Identified
We've identified the issue causing the site to refresh unexpectedly, resulting in users losing content while posting. We're waiting for an update from our vendor to resolve this as quickly as possible. If you need to report an issue, please reach out at https://articulatecase.com. We appreciate your patience and will provide updates as soon as we have more information.
Posted Mar 14, 2025 - 16:43 UTC
Investigating
We're aware of an issue causing the site to refresh unexpectedly, which may result in users losing content while posting. Our team is actively working with our provider to resolve this as quickly as possible. If you need to report an issue, please reach out at https://articulatecase.com. We appreciate your patience and will provide updates as soon as we have more information.