Articulate Internal Systems
Incident Report for Articulate
Resolved
Our scheduled maintenance is complete. Thank you for your patience.
Posted Jan 29, 2024 - 15:56 UTC
Identified
Our scheduled maintenance is still underway. We are working hard to restore everything. Please email us at Support@articulate.com if you need immediate assistance.
Posted Jan 29, 2024 - 14:07 UTC
This incident affected: Articulate ID, Articulate.com and Articulate 360 (Account Management).