Review 360: Newly uploaded Storyline courses fail to load

Incident Report for Articulate

Monitoring

This issue has been resolved. Storyline content uploaded to Review 360 now loads as expected. We’ll continue to monitor performance to ensure everything remains stable.
Posted Apr 29, 2026 - 17:57 UTC

Investigating

We’re investigating an issue where some Review 360 items fail to load.

This is impacting newly uploaded Storyline courses. Existing content continues to work as expected.
Creators may see a loading error or be unable to open newly published content in Review 360.

We’re actively working to identify the cause and will share updates as soon as we have more information.
Posted Apr 29, 2026 - 17:00 UTC
This incident affects: Articulate 360 (Review 360).