Reach 360 and Rise.com Intermittent Errors and Slowness

Incident Report for Articulate

Resolved

Mitigations were implemented for the intermittent 404 errors and degraded performance affecting Reach 360 and Rise.com. Service metrics remained stable during the monitoring period, and the sites are responding normally.

This incident has been resolved.
Posted May 19, 2026 - 19:57 UTC

Monitoring

We implemented mitigations for the intermittent 404 errors and degraded performance affecting Reach 360 and Rise.com. Error rates and service metrics have returned to normal levels, and the sites are currently responding as expected.

We are continuing to monitor service stability and complete any remaining remediation activities.
Posted May 19, 2026 - 18:50 UTC

Update

We continue to investigate intermittent 404 errors and degraded performance affecting Reach 360 and Rise.com. Mitigation efforts are ongoing, and we are monitoring service behavior closely.
Posted May 19, 2026 - 17:45 UTC

Update

We continue to investigate intermittent 404 errors and degraded performance affecting Reach 360 and Rise.com. Mitigation efforts are ongoing, and we are monitoring service behavior closely.
Posted May 19, 2026 - 16:31 UTC

Investigating

We are investigating reports of intermittent 404 errors and degraded performance affecting Reach 360 and Rise.com. Our team has identified elevated probing activity against services and is actively working to mitigate the impact.

Customers may experience intermittent access issues or slower-than-normal performance.
Posted May 19, 2026 - 15:19 UTC
This incident affected: Articulate 360 (Reach 360).