Rise 360 is currently unavailable
Incident Report for Articulate
Resolved
We've confirmed that Rise 360 is working normally.
Posted Jul 23, 2019 - 20:15 UTC
Monitoring
Rise 360 is back up and running normally, and we're monitoring carefully. We'll keep you posted.
Posted Jul 23, 2019 - 17:26 UTC
Investigating
Rise 360 is currently unavailable, and we’re looking into what went wrong. We’ll let you know as soon as we have more info. We’re so sorry for the trouble.
Posted Jul 23, 2019 - 16:51 UTC
This incident affected: Articulate 360 (Rise 360).