Articulate 360: Delayed provisioning for users signing in to Articulate 360 with SSO

Incident Report for Articulate

Monitoring

We’ve fixed the issue that caused delays when provisioning users through SSO in Articulate 360.

Provisioning is now working as expected. Some users may still notice short delays as systems fully catch up.

We’re continuing to monitor the performance to ensure everything remains stable.
Posted May 05, 2026 - 20:52 UTC

Investigating

We’re investigating an issue that delays provisioning for some users signing into Articulate 360 with SSO.

Impacted users may not see the expected access right away. We’ll share an update as soon as we know more.
Posted May 05, 2026 - 20:08 UTC
This incident affects: Articulate 360 (Account Management).