Articulate 360: Image loading issues
Incident Report for Articulate
Resolved
We've confirmed that images in Rise 360 and Review 360 are working normally.
Posted Oct 08, 2019 - 23:29 UTC
Monitoring
Images are now working normally, and we're keeping a careful eye on performance.
Posted Oct 08, 2019 - 22:29 UTC
Investigating
We're seeing issues with images loading across Articulate 360, including Review 360 and Rise 360. You may also have issues exporting Rise 360 courses and uploading images to Rise 360 projects. We're looking into what went wrong and will let you know as soon as we have an update.
Posted Oct 08, 2019 - 21:56 UTC
This incident affected: Articulate 360 (Review 360, Rise 360).