Articulate 360: Intermittent Issues
Incident Report for Articulate
Resolved
This issue is now resolved. Thank you for your patience!
Posted Feb 13, 2024 - 23:58 UTC
Monitoring
Functionality has returned to normal, and you should be able to access account management and billing features again. We're monitoring performance carefully.
Posted Feb 13, 2024 - 22:40 UTC
Identified
Hi, Articulate 360 users! We're working to resolve an issue that preventing access to account management and billing features. We'll let you know as this is fixed. In the meantime, please feel free to reach out to our Support team by emailing support@articulate.com.
Posted Feb 13, 2024 - 21:05 UTC
This incident affected: E-Learning Heroes, Articulate.com and Articulate 360 (Account Management).