Articulate Store Unavailable

Incident Report for Articulate

Resolved

This incident has been resolved. Processing of orders is working as expected.
Posted May 01, 2025 - 20:53 UTC

Investigating

Our team is currently investigating an issue affecting our purchasing pages—specifically, credit card information is not being accepted during checkout. As a result, we're temporarily unable to process orders for Articulate products.

We’re sorry for the trouble and we'll share updates here as soon as we have more information.
Posted May 01, 2025 - 19:20 UTC
This incident affected: Articulate 360 (Account Management).