AI Assistant: Increased latency and failures across AI features

Incident Report for Articulate

Monitoring

AI-powered features are working as expected. We’re continuing to monitor performance closely to ensure services remain stable.
Posted May 27, 2026 - 18:49 UTC

Update

We’re continuing to investigate an issue with our AI service provider that is causing increased latency and higher failure rates across several AI-powered features.
We’ll share another update as soon as we have more information. We’re sorry for the trouble.
Posted May 27, 2026 - 17:49 UTC

Investigating

We’re investigating an issue with our AI service provider that is causing increased latency and higher failure rates across several AI-powered features.
Customers may experience slow responses, timeouts, or failed requests when using AI Writer, AI Course Drafts, Magic Import, block generation and editing, source uploads and processing, quiz generation, text rewrites, summarization, and other AI text generation features.
AI image generation is currently working as expected.
We’re actively monitoring the issue and working with our provider to restore normal performance as quickly as possible.
Posted May 27, 2026 - 16:50 UTC
This incident affects: Articulate 360 (AI Assistant).